package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bYour email:[^\S\n]+([^@\n]+@[\w.,-]+)`)
var str = `Your email: Peter @gmail.com Please enter your spouse's email: Mandy@gmail.com'
Your email: Please enter your spouse's email: Mandy@gmail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}