using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([ATGC]{2});\1(?!.*\1;\1)";
string input = @"AT;GC;TA;CC;AG;AG;CC;CA;TA;TA
TA;TA;GC;TA;CC;AG;AG;CC;CA;TA;TA
AT;AT;AT;AT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}