$re = '/([ATGC]{2});\1(?!.*\1;\1)/m';
$str = 'AT;GC;TA;CC;AG;AG;CC;CA;TA;TA
TA;TA;GC;TA;CC;AG;AG;CC;CA;TA;TA
AT;AT;AT;AT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);