package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d]+[.]{0,1}[\d]+[x|X|*][\d]+[.]{0,1}[\d]+[x|X|*][\d]+[.]{0,1}[\d]+`)
var str = `12*19.2*2000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}