#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<alb_type>(https?|h2|wss?))\s*(?P<alb_timestamp>[^\s]+)\s*(?P<alb_elb>[^\s]+)\s*(?P<alb_client_addr>[^:]+):\s*(?P<alb_client_port>[^\s]+)\s*(?P<alb_target_addr>[^:]+):(?P<alb_target_port>[^\s]+)\s*(?P<alb_request_processing_time>[^\s]+)\s*(?P<alb_target_processing_time>[^\s]+)\s*(?P<alb_response_processing_time>[^\s]+)\s*(?P<alb_elb_status_code>[^\s]+)\s*(?P<alb_target_status_code>[^\s]+)\s*(?P<alb_received_bytes>[^\s]+)\s*(?P<alb_sent_bytes>[^\s]+)\s*"(?P<alb_request>.*?)"\s+"(?P<alb_user_agent>[^\"]+)"\s*(?P<alb_ssl_cipher>[^\s]+)\s*(?P<alb_ssl_protocol>[^\s]+)\s*(?P<alb_target_group_arn>[^\s]+)\s*"(?P<alb_trace_id>[^\"]+)"\s*"(?P<alb_domain_name>[a-zA-Z0-9\.\-:]+)"\s*"(?P<alb_chosen_cert_arn>[^\"]+)"\s*(?P<alb_matched_rule_priority>[^\s]+)\s*(?P<alb_request_creation_time>[^\s]+)\s*\s*"(?P<alb_actions_executed>[^\s]+)"\s*"(?P<alb_redirect_url>[^\s]+)"\s*"(?P<alb_error_reason>[^\"]+)"\s*"?(?P<alb_target_port_list>[0-9 :\.-]+)"?\s*"?(?P<alb_target_status_code_list>[0-9 -]+)"?"
Local $sString = "http 2018-07-02T22:23:00.186641Z app/my-loadbalancer/50dc6c495c0c9188 " & @CRLF & _
"192.168.131.39:2817 10.0.0.1:80 0.000 0.001 0.000 200 200 34 366 " & @CRLF & _
""GET http://www.example.com:80/ HTTP/1.1" "curl/7.46.0" - - " & @CRLF & _
"arn:aws:elasticloadbalancing:us-east-2:123456789012:targetgroup/my-targets/73e2d6bc24d8a067" & @CRLF & _
""Root=1-58337262-36d228ad5d99923122bbe354" "-" "-" " & @CRLF & _
"0 2018-07-02T22:22:48.364000Z "forward" "-" "-" 80 200 " & @CRLF & _
"" & @CRLF & _
"ws 2018-07-02T22:23:00.186641Z app/my-loadbalancer/50dc6c495c0c9188 " & @CRLF & _
"10.0.0.140:40914 10.0.1.192:8010 0.001 0.003 0.000 101 101 218 587 " & @CRLF & _
""GET http://10.0.0.30:80/ HTTP/1.1" "-" - - " & @CRLF & _
"arn:aws:elasticloadbalancing:us-east-2:123456789012:targetgroup/my-targets/73e2d6bc24d8a067" & @CRLF & _
""Root=1-58337364-23a8c76965a2ef7629b185e3" "-" "-"" & @CRLF & _
"1 2018-07-02T22:22:48.364000Z "forward" "-" "-" 80 200" & @CRLF & _
"" & @CRLF & _
"wss 2018-07-02T22:23:00.186641Z app/my-loadbalancer/50dc6c495c0c9188 " & @CRLF & _
"10.0.0.140:44244 10.0.0.171:8010 0.000 0.001 0.000 101 101 218 786" & @CRLF & _
""GET https://10.0.0.30:443/ HTTP/1.1" "-" ECDHE-RSA-AES128-GCM-SHA256 TLSv1.2 " & @CRLF & _
"arn:aws:elasticloadbalancing:us-west-2:123456789012:targetgroup/my-targets/73e2d6bc24d8a067" & @CRLF & _
""Root=1-58337364-23a8c76965a2ef7629b185e3" "-" "-"" & @CRLF & _
"1 2018-07-02T22:22:48.364000Z "forward" "-" "-" "44244" "101"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")