using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<alb_type>(https?|h2|wss?))\s*(?P<alb_timestamp>[^\s]+)\s*(?P<alb_elb>[^\s]+)\s*(?P<alb_client_addr>[^:]+):\s*(?P<alb_client_port>[^\s]+)\s*(?P<alb_target_addr>[^:]+):(?P<alb_target_port>[^\s]+)\s*(?P<alb_request_processing_time>[^\s]+)\s*(?P<alb_target_processing_time>[^\s]+)\s*(?P<alb_response_processing_time>[^\s]+)\s*(?P<alb_elb_status_code>[^\s]+)\s*(?P<alb_target_status_code>[^\s]+)\s*(?P<alb_received_bytes>[^\s]+)\s*(?P<alb_sent_bytes>[^\s]+)\s*""(?P<alb_request>.*?)""\s+""(?P<alb_user_agent>[^\""]+)""\s*(?P<alb_ssl_cipher>[^\s]+)\s*(?P<alb_ssl_protocol>[^\s]+)\s*(?P<alb_target_group_arn>[^\s]+)\s*""(?P<alb_trace_id>[^\""]+)""\s*""(?P<alb_domain_name>[a-zA-Z0-9\.\-:]+)""\s*""(?P<alb_chosen_cert_arn>[^\""]+)""\s*(?P<alb_matched_rule_priority>[^\s]+)\s*(?P<alb_request_creation_time>[^\s]+)\s*\s*""(?P<alb_actions_executed>[^\s]+)""\s*""(?P<alb_redirect_url>[^\s]+)""\s*""(?P<alb_error_reason>[^\""]+)""\s*""?(?P<alb_target_port_list>[0-9 :\.-]+)""?\s*""?(?P<alb_target_status_code_list>[0-9 -]+)""?";
string input = @"http 2018-07-02T22:23:00.186641Z app/my-loadbalancer/50dc6c495c0c9188
192.168.131.39:2817 10.0.0.1:80 0.000 0.001 0.000 200 200 34 366
""GET http://www.example.com:80/ HTTP/1.1"" ""curl/7.46.0"" - -
arn:aws:elasticloadbalancing:us-east-2:123456789012:targetgroup/my-targets/73e2d6bc24d8a067
""Root=1-58337262-36d228ad5d99923122bbe354"" ""-"" ""-""
0 2018-07-02T22:22:48.364000Z ""forward"" ""-"" ""-"" 80 200
ws 2018-07-02T22:23:00.186641Z app/my-loadbalancer/50dc6c495c0c9188
10.0.0.140:40914 10.0.1.192:8010 0.001 0.003 0.000 101 101 218 587
""GET http://10.0.0.30:80/ HTTP/1.1"" ""-"" - -
arn:aws:elasticloadbalancing:us-east-2:123456789012:targetgroup/my-targets/73e2d6bc24d8a067
""Root=1-58337364-23a8c76965a2ef7629b185e3"" ""-"" ""-""
1 2018-07-02T22:22:48.364000Z ""forward"" ""-"" ""-"" 80 200
wss 2018-07-02T22:23:00.186641Z app/my-loadbalancer/50dc6c495c0c9188
10.0.0.140:44244 10.0.0.171:8010 0.000 0.001 0.000 101 101 218 786
""GET https://10.0.0.30:443/ HTTP/1.1"" ""-"" ECDHE-RSA-AES128-GCM-SHA256 TLSv1.2
arn:aws:elasticloadbalancing:us-west-2:123456789012:targetgroup/my-targets/73e2d6bc24d8a067
""Root=1-58337364-23a8c76965a2ef7629b185e3"" ""-"" ""-""
1 2018-07-02T22:22:48.364000Z ""forward"" ""-"" ""-"" ""44244"" ""101""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}