#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d.]+-[\d.]+)\s+sec\s+([\d.]+\s+\w?Bytes)\s+([\d.]+\s+\w?bits/sec)[\s\w]+receiver"
Local $sString = "Connecting to host 9.10.21.01, port 5201" & @CRLF & _
"[ 4] local 9.17.201.011 port 44466 connected to 9.10.21.01 port 5201" & @CRLF & _
"[ ID] Interval Transfer Bandwidth Retr Cwnd" & @CRLF & _
"[ 4] 0.00-2.00 sec 1.71 GBytes 7.36 Gbits/sec 264 789 KBytes" & @CRLF & _
"[ 4] 2.00-4.00 sec 1.63 GBytes 6.99 Gbits/sec 133 865 KBytes" & @CRLF & _
"[ 4] 4.00-5.00 sec 732 MBytes 6.14 Gbits/sec 11 826 KBytes" & @CRLF & _
"- - - - - - - - - - - - - - - - - - - - - - - - -" & @CRLF & _
"[ ID] Interval Transfer Bandwidth Retr" & @CRLF & _
"[ 4] 0.00-5.00 sec 4.06 GBytes 6.97 Gbits/sec 408 sender" & @CRLF & _
"[ 4] 0.00-5.00 sec 4.05 GBytes 6.96 Gbits/sec receiver"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")