import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\d.]+-[\\d.]+)\\s+sec\\s+([\\d.]+\\s+\\w?Bytes)\\s+([\\d.]+\\s+\\w?bits/sec)[\\s\\w]+receiver";
final String string = "Connecting to host 9.10.21.01, port 5201\n"
+ "[ 4] local 9.17.201.011 port 44466 connected to 9.10.21.01 port 5201\n"
+ "[ ID] Interval Transfer Bandwidth Retr Cwnd\n"
+ "[ 4] 0.00-2.00 sec 1.71 GBytes 7.36 Gbits/sec 264 789 KBytes\n"
+ "[ 4] 2.00-4.00 sec 1.63 GBytes 6.99 Gbits/sec 133 865 KBytes\n"
+ "[ 4] 4.00-5.00 sec 732 MBytes 6.14 Gbits/sec 11 826 KBytes\n"
+ "- - - - - - - - - - - - - - - - - - - - - - - - -\n"
+ "[ ID] Interval Transfer Bandwidth Retr\n"
+ "[ 4] 0.00-5.00 sec 4.06 GBytes 6.97 Gbits/sec 408 sender\n"
+ "[ 4] 0.00-5.00 sec 4.05 GBytes 6.96 Gbits/sec receiver";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}