import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[0-9]+(?:[.,][0-9]+)*[ \\t]+(?:Euro|PESO URUGUAY|U\\$S EEUU|REAL|LIBRA ESTERLINA|PESO CHILENO)";
final String string = "Monto: 150,00 Euro\n"
+ "Monto: 7.350,00 PESO URUGUAY | Pesos: 12.495,00 | Sucursal: 36|\n"
+ "Monto: 2.500,00 PESO URUGUAY\n"
+ "Monto: 200,00 U$S EEUU | Pesos: 12.550,00\n"
+ "Monto: 50,00 U$S EEUU\n"
+ "Monto: 700,00 REAL | Pesos: 10.500,00 | Sucursal: 101\n"
+ "Monto: 100,00 LIBRA ESTERLINA | Pesos: 8.500,00 | Sucursal: 12\n"
+ "Monto: 5.000,00 PESO CHILENO | Pesos: 400,00 | Sucursal: 101";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}