import re
regex = re.compile(r"\b[0-9]+(?:[.,][0-9]+)*[ \t]+(?:Euro|PESO URUGUAY|U\$S EEUU|REAL|LIBRA ESTERLINA|PESO CHILENO)", flags=re.MULTILINE)
test_str = ("Monto: 150,00 Euro\n"
"Monto: 7.350,00 PESO URUGUAY | Pesos: 12.495,00 | Sucursal: 36|\n"
"Monto: 2.500,00 PESO URUGUAY\n"
"Monto: 200,00 U$S EEUU | Pesos: 12.550,00\n"
"Monto: 50,00 U$S EEUU\n"
"Monto: 700,00 REAL | Pesos: 10.500,00 | Sucursal: 101\n"
"Monto: 100,00 LIBRA ESTERLINA | Pesos: 8.500,00 | Sucursal: 12\n"
"Monto: 5.000,00 PESO CHILENO | Pesos: 400,00 | Sucursal: 101")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")