const regex = new RegExp('a(?=b)', 'gm')
const str = `abc`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);