use strict;
my $str = 'abc';
my $regex = qr/a(?=b)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";