#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Exception:)(?!.*\1)(?<exception>.+),\s+Job"
Local $sString = "Exception:100 : *** Error 3006 Logons are disabled., Job=ABC" & @CRLF & _
"Exception:XYZ API has failed. Exception: RDBMS error 2801: Duplicate unique prime key error, Job=ABC" & @CRLF & _
"Exception:100 : RDBMS error 2640: Specified table either does not exist in DEX or is moved to another map., Job=ABC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")