re = /(Exception:)(?!.*\1)(?<exception>.+),\s+Job/m
str = 'Exception:100 : *** Error 3006 Logons are disabled., Job=ABC
Exception:XYZ API has failed. Exception: RDBMS error 2801: Duplicate unique prime key error, Job=ABC
Exception:100 : RDBMS error 2640: Specified table either does not exist in DEX or is moved to another map., Job=ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end