re = /(?:\bdigit-|\s|^)(\d{4})(?=[.?\s]|-digit\b|$)/m
str = '1234 Lorem ipsum 3400-digit, sit amet 5000 consectetur adipisicing elit. Natus, explicabo 6700? Itaque iure ipsum laboriosam, ex nemo delectus iste quia cupiditate digit-9134? Iste nam digit-2456 at voluptate est 8456-digit? At excepturi quis voluptatibus 7500. 1235'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end