const regex = /[\x{1F600}-\x{1F64F}]/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\x{1F600}-\\x{1F64F}]', 'u')
const str = `😄 sdsdfgfg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}