const regex = new RegExp('(?<=<comment>)(?:(?!<\\/comment>).)*', '')
const str = `"<xml><comment>Lorem ipsum dolor sit amet[{'name' : 'Mario Rossi'}]</comment></xml>"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}