re = /(?<=<comment>)(?:(?!<\/comment>).)*/
str = '"<xml><comment>Lorem ipsum dolor sit amet[{\'name\' : \'Mario Rossi\'}]</comment></xml>"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end