package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*?<\/a>`)
var str = `<a href=”/home”>ホーム</a><a href=”/page”>ページ</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}