$re = '/<a.*?<\/a>/';
$str = '<a href=”/home”>ホーム</a><a href=”/page”>ページ</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);