using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^5((\d)(?!\2)\d)\1{3}$";
string input = @"261616161
561616161
555555555
532323232
512312312
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}