#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0?7[4-9]{1}[0-9]{8}$"
Local $sString = "07901611249" & @CRLF & _
"7901611249" & @CRLF & _
"7812304777" & @CRLF & _
"7812345678" & @CRLF & _
"7901123456" & @CRLF & _
"07901234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")