package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z](?:[\doO] ?){4}[\doO]$`)
var str = `R20209
R4 01 08
R5 0801`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}