#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^RXHOST|^rxhost)([a-zA-Z0-9\s\-].*\-{2,}[a-zA-Z0-9\s\-].*|[a-zA-Z0-9\s\-].*\s{2,}[a-zA-Z0-9\s\-].*)"
Local $sString = "RXHOST ZZ PQ1-P-TAS-QZV4YTTT5645644-SIT-01JAN79-VL-01JAN30-MANAGE-TIME-OVER ALL-H/F1/Z3" & @CRLF & _
"RXHOST ZZ PQ1-A-TAS-XZV456NGFF45644-MIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-H/F1/Z3" & @CRLF & _
"RXHOST ZZ PQ1-I-TAS-BZV456456FF44-GIT-01JAN79-VL-01JAN30-MANAGEMENT-TIME/F1/Z3" & @CRLF & _
"" & @CRLF & _
"RXHOST ZZ PQ1-D-TAS-UZV4QQ5645644-SIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-OVER ALL-H/F1" & @CRLF & _
"RXHOST ZZ PQ1-F-TAS-TZV45QDF645644-SIT-01JAN79-V-01JAN30-MANAGE-TIME-H/F1" & @CRLF & _
"RXHOST ZZ PQ1-P-TAS-PZV45FF645644-SIT-01JAN79-JL-01JAN30-MANAGEMENT-TIME/F1" & @CRLF & _
"" & @CRLF & _
"RXHOST ZZ PQ1-P-TAS-QZV456FBF45644-QIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-OVER ALL-H/Z3" & @CRLF & _
"RXHOST ZZ PQ1-I-SAT-TZV456FGF45644-EIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-H/Z3" & @CRLF & _
"RXHOST ZZ PQ1-P-SAT-OZV456EWEW45644-TIT-01JAN79-VL-01JAN30-MANAGE-TIME/Z3" & @CRLF & _
"" & @CRLF & _
"RXHOST ZZ PQ1-P-SAT-ZZV456GFG45644-SIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-OVER ALL-H" & @CRLF & _
"RXHOST ZZ PQ1-D-SAT-XZV4HHH5645644-YIT-01JAN79-V-01JAN30-MANAGE-TIME-H" & @CRLF & _
"RXHOST ZZ PQ1-A-SAT-JZVOPPO45645644-PIT-01JAN79-JL-01JAN30-MANAGEMENT-TIME" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")