# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^RXHOST|^rxhost)([a-zA-Z0-9\s\-].*\-{2,}[a-zA-Z0-9\s\-].*|[a-zA-Z0-9\s\-].*\s{2,}[a-zA-Z0-9\s\-].*)"
test_str = ("RXHOST ZZ PQ1-P-TAS-QZV4YTTT5645644-SIT-01JAN79-VL-01JAN30-MANAGE-TIME-OVER ALL-H/F1/Z3\n"
"RXHOST ZZ PQ1-A-TAS-XZV456NGFF45644-MIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-H/F1/Z3\n"
"RXHOST ZZ PQ1-I-TAS-BZV456456FF44-GIT-01JAN79-VL-01JAN30-MANAGEMENT-TIME/F1/Z3\n\n"
"RXHOST ZZ PQ1-D-TAS-UZV4QQ5645644-SIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-OVER ALL-H/F1\n"
"RXHOST ZZ PQ1-F-TAS-TZV45QDF645644-SIT-01JAN79-V-01JAN30-MANAGE-TIME-H/F1\n"
"RXHOST ZZ PQ1-P-TAS-PZV45FF645644-SIT-01JAN79-JL-01JAN30-MANAGEMENT-TIME/F1\n\n"
"RXHOST ZZ PQ1-P-TAS-QZV456FBF45644-QIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-OVER ALL-H/Z3\n"
"RXHOST ZZ PQ1-I-SAT-TZV456FGF45644-EIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-H/Z3\n"
"RXHOST ZZ PQ1-P-SAT-OZV456EWEW45644-TIT-01JAN79-VL-01JAN30-MANAGE-TIME/Z3\n\n"
"RXHOST ZZ PQ1-P-SAT-ZZV456GFG45644-SIT-01JAN79-V-01JAN30-MANAGEMENT-TIME-OVER ALL-H\n"
"RXHOST ZZ PQ1-D-SAT-XZV4HHH5645644-YIT-01JAN79-V-01JAN30-MANAGE-TIME-H\n"
"RXHOST ZZ PQ1-A-SAT-JZVOPPO45645644-PIT-01JAN79-JL-01JAN30-MANAGEMENT-TIME\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.