#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\s]+\([\w\s]+\)$"
Local $sString = "SINGAPORE (ABC)" & @CRLF & _
"WASHINGTON DC (ABC)" & @CRLF & _
"HONG KONG (ABC)" & @CRLF & _
"NEW YORK (ABC)" & @CRLF & _
"HO CHI MINH CITY VIETNAM (ABC)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")