package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\s]+\([\w\s]+\)$`)
var str = `SINGAPORE (ABC)
WASHINGTON DC (ABC)
HONG KONG (ABC)
NEW YORK (ABC)
HO CHI MINH CITY VIETNAM (ABC)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}