const regex = /(?m)^(?!MAT\s)year\s\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(?!MAT\\s)year\\s\\d{4}$', 'gm')
const str = `MAT year 2019
MAT year 2020
MAT year 2021
year 2016
year 2017
year 2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}