$re = '/(?m)^(?!MAT\s)year\s\d{4}$/m';
$str = 'MAT year 2019
MAT year 2020
MAT year 2021
year 2016
year 2017
year 2018';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);