#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d (?![A-Z]*BNB)([A-Z]+)"
Local $sString = "['Sender Receiver Amount Currency'," & @CRLF & _
" '0x10ed43c718714eb63d5aa57b78b54704e256024e'," & @CRLF & _
" '0x5b9f811d38fc6c1017e0774c552235b33f564deb'," & @CRLF & _
" '1.00 WBNB'," & @CRLF & _
" '0x10ed43c718714eb63d5aa57b78b54704e256024e'," & @CRLF & _
" '0xbb4cdb9cbd36b01bd1cbaebf2de08d9173bc095c'," & @CRLF & _
" '1.00 BNB'," & @CRLF & _
" '0x5b9f811d38fc6c1017e0774c552235b33f564deb'," & @CRLF & _
" '0x6b1ecb203d82fec24f8b684f7906ef98ec9abf0a'," & @CRLF & _
" '596.32 RBH'," & @CRLF & _
" '0x6b1ecb203d82fec24f8b684f7906ef98ec9abf0a'," & @CRLF & _
" '0x10ed43c718714eb63d5aa57b78b54704e256024e'," & @CRLF & _
" '1.00 BNB'," & @CRLF & _
" '0xbb4cdb9cbd36b01bd1cbaebf2de08d9173bc095c'," & @CRLF & _
" '0x10ed43c718714eb63d5aa57b78b54704e256024e'," & @CRLF & _
" '1.00 WBNB']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")