import re
regex = re.compile(r"\d (?![A-Z]*BNB)([A-Z]+)", flags=re.MULTILINE)
test_str = ("['Sender Receiver Amount Currency',\n"
" '0x10ed43c718714eb63d5aa57b78b54704e256024e',\n"
" '0x5b9f811d38fc6c1017e0774c552235b33f564deb',\n"
" '1.00 WBNB',\n"
" '0x10ed43c718714eb63d5aa57b78b54704e256024e',\n"
" '0xbb4cdb9cbd36b01bd1cbaebf2de08d9173bc095c',\n"
" '1.00 BNB',\n"
" '0x5b9f811d38fc6c1017e0774c552235b33f564deb',\n"
" '0x6b1ecb203d82fec24f8b684f7906ef98ec9abf0a',\n"
" '596.32 RBH',\n"
" '0x6b1ecb203d82fec24f8b684f7906ef98ec9abf0a',\n"
" '0x10ed43c718714eb63d5aa57b78b54704e256024e',\n"
" '1.00 BNB',\n"
" '0xbb4cdb9cbd36b01bd1cbaebf2de08d9173bc095c',\n"
" '0x10ed43c718714eb63d5aa57b78b54704e256024e',\n"
" '1.00 WBNB']")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")