use strict;
my $str = 'aa12345
aa12345bb23456
aa12345bb23456cc34567
.aa12345bb23456cc34567
aa12345bb23456cc34567.
aa12345 bb23456 cc34567
aa12345.bb23456.cc34567
';
my $regex = qr/((?<![0-9àâäéèêëîïôöùûü\/:.,!&#`|])[a-zA-Z]{2}[0-9]{5,6}(?![0-9àâäéèêëîïôöùûü\/:.,!&#`|]).*?){3,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}