import Foundation
let pattern = ##"((?<![0-9àâäéèêëîïôöùûü\/:.,!&#`|])[a-zA-Z]{2}[0-9]{5,6}(?![0-9àâäéèêëîïôöùûü\/:.,!&#`|]).*?){3,}"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aa12345
aa12345bb23456
aa12345bb23456cc34567
.aa12345bb23456cc34567
aa12345bb23456cc34567.
aa12345 bb23456 cc34567
aa12345.bb23456.cc34567
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)