$re = '/([^=]+)=["\']([^\'"]+)["\']/is';
$str = 'href=\'www.google.com\' target="_blank" title="S"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);