re = /([^=]+)=["']([^'"]+)["']/i
str = 'href=\'www.google.com\' target="_blank" title="S"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end