use strict;
my $str = 'http://youtu.be/cCnrX1w5luM
www.youtube.com/cCnrX1w5luM
youtu.be/cCnrX1w5luM
https://www.youtube.com/watch?v=nzj7Wg4DAbs
http://www.youtube.com/watch?v=nzj7Wg4DAbs
youtube.com/watch?v=nzj7Wg4DAbs
http://www.youtube.com/watch?v=-wtIMTCHWuI
http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1
http://youtu.be/-wtIMTCHWuI
http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json
Hello https://www.youtube.com/watch?v=nzj7Wg4DAbs world
';
my $regex = qr/(.*) ((youtube.com) | (youtu.be) | (www.youtube.com) ) (.*)/mixp;
my $subst = '<iframe src="htpp://youtube.com$6" allowfullscreen></iframe>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";