# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(.*) ((youtube.com) | (youtu.be) | (www.youtube.com) ) (.*)
"""
test_str = ("http://youtu.be/cCnrX1w5luM\n"
"www.youtube.com/cCnrX1w5luM \n"
"youtu.be/cCnrX1w5luM\n"
"https://www.youtube.com/watch?v=nzj7Wg4DAbs\n"
"http://www.youtube.com/watch?v=nzj7Wg4DAbs\n"
"youtube.com/watch?v=nzj7Wg4DAbs\n"
"http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"http://youtu.be/-wtIMTCHWuI\n"
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"Hello https://www.youtube.com/watch?v=nzj7Wg4DAbs world\n")
subst = "<iframe src=\"htpp://youtube.com$6\" allowfullscreen></iframe>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.