using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^gallery-a(?!.*clip-a).*";
string input = @"gallery-a
gallery-a kfjrgrgl elrgkelk
gallery-a clip-a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}