$re = '/^gallery-a(?!.*clip-a).*/m';
$str = 'gallery-a
gallery-a kfjrgrgl elrgkelk
gallery-a clip-a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);