$re = '/(#(\w+))/m';
$str = 'cett #chaine de carctères #permet de #trouver des #hashtags';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);