using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Cluster\[(?<string1>[^\.]+)\.(?<string2>[^\]]+)";
string input = @"2022-02-01 11:59:59,869 INFO CUS.AbCD-Host-000000 [AppListener] Receive Packet[0000000*]: Cluster[String1.String2]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}