re = /Cluster\[(?<string1>[^\.]+)\.(?<string2>[^\]]+)/m
str = '2022-02-01 11:59:59,869 INFO CUS.AbCD-Host-000000 [AppListener] Receive Packet[0000000*]: Cluster[String1.String2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end