using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*[a-z_]+\w*";
string input = @"Abcd abcd1a 5ever a qw3-fne superb5 1234 0 99ballons 5roses4you _abcdefg -9 0_avg self-employed.2 arg_c";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}