package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\d*[a-z_]+\w*`)
var str = `Abcd abcd1a 5ever a qw3-fne superb5 1234 0 99ballons 5roses4you _abcdefg -9 0_avg self-employed.2 arg_c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}