re = /(<u>)(.*?)(<\/u>)/
str = 'und <u>Schadstofffreisetzung</u>bei Reinigungs-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end