import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\\\r\\n]*)(:?\\\\r)?$";
final String string = "0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\\r\n"
+ "0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\n"
+ "0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\\r";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}