import re
regex = re.compile(r"^([^\\r\n]*)(:?\\r)?$", flags=re.MULTILINE)
test_str = ("0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\\r\n"
"0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\n"
"0.43,0.57,0.71,0.29,0.71,1.00,0.57,1.00\\r")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")