$re = '/.+\.{a-z}+$/m';
$str = 'DELETE *
FROM albums
WHERE YEAR = \'2018\'
AND pic NOT LIKE \'%.j%\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);