re = /.+\.{a-z}+$/m
str = 'DELETE *
FROM albums
WHERE YEAR = \'2018\'
AND pic NOT LIKE \'%.j%\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end