package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^.*aut[^\s]*\s+[^\s]*co.*$`)
var str = `Astronaut control
Autonomous company
Autocomplete`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}